Шер Не красота спасет мир, а резервное копирование


Меню


Конфигурирование и администратирование
Выполняем начальное заполнение

Гостевая книга



СПД
Лимит остатка товара
Универсальный отчет


Подключаем сканер штрих кода

Самый простой документ (СПД)

Пишем документ с нуля в 1С

// 1С:Предприятие 8.1 (8.1.15.14)

Возникла необходимость создать документ с нуля в 1С, сам по себе документик простой, информации несем в себе не много, движение по регистру бухгалтерии создает простейшее, но проводка должна, естественно, полностью соответствовать проводкам стандартного документа 1С – ПКО. Новый документ будет отслеживать сбор денег с сотрудников фирмы SetLinks error: Incorrect password!


Пишем документ с нуля в 1С
рисунок 1

Функционально документ должен собрать собранные суммы и, естественно сложить их. Поле сотрудник должно фиксировать ответственного товарища, который потом получит собранную сумму для его целевого использования.

Пишем документ с нуля в 1С
рисунок 2

К документу выдвигаются минимальные требования

  1. Дата должна формироваться с точностью до секунды
  2. Поле Касса, должна при открытии автоматически заполняться кассой национальной валюты
  3. Настроили представление полей
  4. Задали начальные настройки

1. Дата с секундами

Для формировании Даты с секундами, логически напрашивается вставить нужный код в Процедура ПриОткрытии

Процедура ПриОткрытии()
	Если ЭтоНовый() Тогда
		 ЭтотОбъект.Дата = ТекущаяДата();
	КонецЕсли;
КонецПроцедуры

Результат не заставил себя ждать

Пишем документ с нуля в 1С
рисунок 3

Если есть желание добавить немножко креативчика, то можно вывести дату, которая, например, на двое суток позже даты BIOSа вашего компьютера

Процедура ПриОткрытии()
	Если ЭтоНовый() Тогда
		 ЭтотОбъект.Дата = ТекущаяДата() - 60*60*24*2;
	КонецЕсли;
КонецПроцедуры


2. Заполняем поле Касса

При открытии документа, мы хотим, что бы Поле Касса автоматически заполнялось кассой национальной валюты, точно так же как это делается в стандартной конфигурации 1С (рисунок 4)

Пишем документ с нуля в 1С
рисунок 4


Конечно, очень странно, что метод обращения к предопределенным элементам в Конфигураторе, который проповедуется всеми курсами и методическими рекомендациями в изучении 1С, напрочь отсутствует в базовой конфигурации в отношении справочника Кассы

Справочник <b>Кассы</b>: Предопределенные элементы справочника

Справочник Кассы: Предопределенные элементы справочника

Вот так мы видим Справочник Кассы в Конфигураторе

рисунок 5

Справочник Кассы

Справочник Кассы

А вот так мы видим Справочник Кассы уже через бухгалтерский интерфейс

рисунок 6
Процедура ПриОткрытии()
	Если ЭтоНовый() Тогда
		 ЭтотОбъект.Дата = ТекущаяДата() - 60*60*24*2;
		Касса = Справочники.Кассы.НайтиПоНаименованию("Основная касса");		
	КонецЕсли;
КонецПроцедуры

SetLinks error: Incorrect password!


SetLinks error: Incorrect password!

Дальше

Монеты Таджикистана

Монеты Аргентины





Деловые партнеры из Китая
Rambler's Top100