Шер Не красота спасет мир, а резервное копирование


Меню


Конфигурирование и администратирование
Выполняем начальное заполнение

Гостевая книга



СПД
Лимит остатка товара
Универсальный отчет


Подключаем сканер штрих кода

Лимит остатка товара

Материальная ведомость

// 1С:Предприятие 8.1 (8.1.15.14)

Думаю, никто не будет со мной спорить, если скажу, Отчет «Материальная ведомость» в 1С Бухгалтерия 8.1 – просто великолепная вещь! Благодаря тому, что в этом отчете в начальном и конечном сальдо выдается учетная цена номенклатуры, Материальная ведомость является одним из трех, самых популярных отчетов среди пользователей, особенно из числа его руководящего состава SetLinks error: Incorrect password!

Материальная ведомость 1С 8.1
рисунок 1

Думаю, никто не будет со мной спорить, если скажу, Отчет «Материальная ведомость» в 1С Бухгалтерия 8.1 – просто великолепная вещь! Благодаря тому, что в этом отчете в начальном и конечном сальдо выдается учетная цена номенклатуры, Материальная ведомость является одним из трех, самых популярных отчетов среди пользователей, особенно из числа его руководящего состава

Неплохо этот отчет помогает Отделу Закупок следить за наличием необходимого количества сырья, материалов и товара. На производственном предприятии, где и номенклатуры, и поставщиков не так много, к тому же от 1С Бухгалтерии не всегда требуется следить за минимальным остатком сырья, Материальная ведомость и по сей день актуальна

Однако, в настоящее время, 1С-кой вооружаются торговые фирмы, у которых и количества товара и количества поставщиков – необъятное множество. Работники складов не в состоянии обеспечить фактический контроль за лимитами. В этом им должна помочь 1С если возьмет на себя контроль за установленным лимитом по каждому товару

Лимит остатка товара. (Материальная ведомость)
рисунок 2

Тут то и возникает мысль апгрейдить отчет «Материальная ведомость», ведь там то и нужно, что добавить три колонки: Поставщик, Лимит и Контроль лимита (на рисунке 2 – колонка ОстатокПоЛимиту)



***

Пишем документ с нуля в 1С
рисунок 2

К документу выдвигаются минимальные требования

  1. Дата должна формироваться с точностью до секунды
  2. Поле Касса, должна при открытии автоматически заполняться кассой национальной валюты
  3. Настроили представление полей
  4. Задали начальные настройки

1. Дата с секундами

Пишем документ с нуля в 1С
рисунок 3

Если есть желание добавить немножко креативчика, то можно вывести дату, которая, например, на двое суток позже даты BIOSа вашего компьютера

Процедура ПриОткрытии()
	Если ЭтоНовый() Тогда
		 ЭтотОбъект.Дата = ТекущаяДата() - 60*60*24*2;
	КонецЕсли;
КонецПроцедуры


2. Заполняем поле Касса

При открытии документа, мы хотим, что бы Поле Касса автоматически заполнялось кассой национальной валюты, точно так же как это делается в стандартной конфигурации 1С (рисунок 4)

Пишем документ с нуля в 1С
рисунок 4


Конечно, очень странно, что метод обращения к предопределенным элементам в Конфигураторе, который проповедуется всеми курсами и методическими рекомендациями в изучении 1С, напрочь отсутствует в базовой конфигурации в отношении справочника Кассы

Справочник <b>Кассы</b>: Предопределенные элементы справочника

Справочник Кассы: Предопределенные элементы справочника

Вот так мы видим Справочник Кассы в Конфигураторе

рисунок 5

Справочник Кассы

Справочник Кассы

А вот так мы видим Справочник Кассы уже через бухгалтерский интерфейс

рисунок 6
Процедура ПриОткрытии()
	Если ЭтоНовый() Тогда
		 ЭтотОбъект.Дата = ТекущаяДата() - 60*60*24*2;
		Касса = Справочники.Кассы.НайтиПоНаименованию("Основная касса");		
	КонецЕсли;
КонецПроцедуры

SetLinks error: Incorrect password!


SetLinks error: Incorrect password!

Дальше

Монеты Таджикистана

Монеты Аргентины





Деловые партнеры из Китая
Rambler's Top100